New Device Issues

Comments

13 comments

  • Pokit Support Team

    Hi Russ,

    The problem with Pokit measuring nothing is related to the fuse. When you removed and placed the fuse back in, it might have not made good contact. Please remove the fuse and make sure the cover clicks-in correctly and the fuse is properly pushed against Pokit PCB.

     

    Let us know how you go.

    Thanks

    1
    Comment actions Permalink
  • George Riggall

    I was also having difficulty connecting to my PokitMeter. I removed the fuse and the solder blobs on the back were very grey and looked a bit crusty. I gave them a bit of a clean and now I can actually connect! Much better :D

    0
    Comment actions Permalink
  • Russ Gillenwater

    Good tip.  I went back and tried all of that, and the fuse solder blobs are nice and shiny and the pwa contact look clean, too (I’m using a magnifier to check this.  The fuse seems to be seated properly, though the fuse cover bulges (on both fuses) when it is in place.   All four locking tabs seat correctly.  So, I’m thinking it’s a mechanical or contact failure with the leads.  I’m hesitant to strip it down completely.

    Even if the fuse connection is bad, the temperature shouldn’t read 97F after sitting in a 68F room for 24 hours.  Unless it’s on a chip, in which case it would just read the chip twmperature instead of the ambient.  I don’t know where it is located, but I can’t imagine the desigers using chip temps for ambient measurements.

    So, I’m back to thinking it really is broken.

    I did try opening a ticket, but I’ve had no response at all.  Does anyone know how I get a response from the support team?   email doesn’t seem to work.  I’d really like to resolve this and get a working pokit.

    thanks  -russg

    0
    Comment actions Permalink
  • Russ Gillenwater

    Final update, I went back and gently sanded the solder balls on the bottom of one fuse flat, so the end tabs now click into the slots in the mother board and the fuse cover snaps into place without bulging.  I get the same results (no voltage, resistance, etc readings) with the weird exception that the o-scope now displays a 20kHz square wave as a triangular waveform at 20kHz.  So, I’m considering it defective and have shipped it back.  I’m looking forward to receiving a working unit!

     

    0
    Comment actions Permalink
  • Chuck

    I just received my device, removed the paper insulator under the battery and did not work. I scraped the top of the solder blobs and the device is still nit working? The app has the message "Ensure your PockitMeter is powered up.." and that is far as I get after cleaning the battery contacts and restarting the app multiple times.

     

    What now?

    0
    Comment actions Permalink
  • Chuck

    I went back, sanded the solder blobs, inserted fuse with blobs on bottom touching the contacts, made sure the fuse retainer was all the way in, measured the battery - 3.2 V and restarted the app. Still not working. Please send a replacement.

    0
    Comment actions Permalink
  • Pokit Support Team

    Dear all,

     We have recently noticed that the BLE connection is not working properly on some Android devices. We forwarded this issue to our Dev Team and we are looking into this problem now. We will keep you updated as soon as we find the issue and release an app update to fix it. 

    Before asking you to return your Pokits, we'll ask you for a few days until we find the connection problem and solve it on the app.

    Thanks and sorry for the inconvenience.

    Cheers,

    1
    Comment actions Permalink
  • jaubroome

    Support team,
    Still waiting for the android fix. The few dsys is now a 3 weeks. Any update?

    0
    Comment actions Permalink
  • Russ Gillenwater

    Has anyone heard from support?  

    I returned my Pokit for replacement (which was delivered about two weeks ago) but haven’t heard anything despite emails.  I’d like to make sure it was received and not stollen off a porch and find out when my replacement/repaired unit will ship back.

    I understand there might be delays - I really do want a working PokitMeter & I love the product - and I’m willing to wait but I also need a response.

    cheers - russg

    0
    Comment actions Permalink
  • jaubroome

    After I read the post above from Support team about the problems with some versions of android, I submitted a support request detailing the versions of android that I could not connect with.  That was 3 weeks ago.  Have heard nothing since.  The post above suggests waiting a few days.

    0
    Comment actions Permalink
  • John Battersby

    I am also struggling with getting any meaningful support. My Poikit appears to be dead-on-arrival and despite having raised three service request tickets and sending several e-mails, I am still not getting any replies. Having read through several threads in this discussion forum, I get the feeling I am not alone and perhaps Pokit HQ knows there is a fundamental issue with some units.... hence the silence....

    0
    Comment actions Permalink
  • jaubroome

    I have now received a reply and request for more information, so someone is listening.  Will await fix for App problems.

    0
    Comment actions Permalink
  • Edon van Hees

    I have the same problem and I want a response too

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk