Skip to main content

Android app sees device but gives a connect failed 1 minute later



  • Kevin Walters

    I borrowed a friend with a more recent version of Android on his smartphone. The Pokit app on that initially looked promising, it connected to the Pokit reporting firmware v1.2. The upgrade failed about half way through to v1.4. Tried three times, all failed to upgrade. This is never a pleasant feeling either, as half an upgrade can be a "bricking" event depending on design of the mechanism.

    Moved on to an iOS smartphone. That connected and managed to get the firmware to v1.4. We did briefly see a voltage reading too but that was flaky and stopped working.

    The v1.4 firmware has not changed behaviour on my Android 5 tablet, still can't connect.

    Overall, I'm not impressed by this. I was going to make this Pokit a gift but with the state of the software as is it's too unreliable and hence embarrassing to gift.


  • Pokit Support Team

    Hi Kevin,

    Apologies for the inconveniences you are having. This means that Pokit is not compatible with your Android tablet. There are more than 22000 Android devices and as you may see we are unable to test against all of them. We do support most mainstream Android devices though and definitely all iOS devices not older than 5 years.


    Firmware revision fixed most connectivity issues with many devices. The ones left without connectivity were because it is not a problem with our firmware but with Android.

    May I know which tablet model and software version are you trying to use?


    Hope you understand.


  • Tomas Rakusan


    I am also having this issue and I have a OnePlus 3 running OxygenOS 5.0.8 (Android 8.0.0)

    Also my device had worked the last time I tried it in March with the last time I updated my phone being before I had even received my pokit in December.

  • Kevin Walters

    These are the versions, I'd already mentioned first one in first post:

    • HUDL 2 tablet - Android 5.1 - Pokit app v1.0.1 - connect fails half way against Pokit on v1.2 and v1.4
    • Samsung Galaxy S7 - Android 8.0.0 - connects but firmware update from v1.2 to v1.4 fails half way through
    • iPhone 6 - iOS 12.1.4 - upgraded firmware ok from v1.2 to v1.4, worked for about a minute on the voltage measurement, then stopped working

    It would be good if you published and actively maintained a list of devices or o/s or combinations that are:

    • known to work,
    • known not to work,
    • may work.

    The Pokit app in the Google Play Store is marked up as working on Android 5 and above, btw. If this doesn't work on Android 5 then perhaps that's worth changing?

    At the moment I find it hard to recommend this product based on my Android experience and I'm starting to wish I hadn't participated in the Kickstarter project.

  • Kevin Walters

    It would also be useful if the app when it failed to connect gave the option for the user to see all the gory details to allow use to pass those back to Pokit for analysis.

  • Ernst Klomp

    I have the exact same issue as Kevin Walters
    Samsung Galaxy S7 - Android 8.0.0 - connects but firmware update from v1.2 to v1.4 fails half way through

    When I got the Pokit with 1.2 it worked perfectly.

    S7 supports BLE...

  • Alexander Valentin

    Observing the same behavior on both my Samsung Galaxy Tab S6 and Pixel 4XL...trues to connect and returns the error message. Used to be able to connect on my LG V20 but for some reason it's no longer connecting. 


    Is there a workaround to updating the firmware on the Pokit? This in hope that it solves the connection issues with the newer devices. 

  • Alexander Valentin

    Finally got it updated to the latest firmware using Pixel 4XL. Deleted cache and data in the app...first connected directly through phone`s BT to the pokit then disconnected and went through the app prompt, connected and update went through. 


Please sign in to leave a comment.

Powered by Zendesk