Skip to main content

"Ensure your Pokit Meter is powered up,,," Edit: Fixed with firmware update!




  • Zoroaster Kagami

    me too...

  • Pokit Support Team

    Hey guys,


    May I know what mobile device are you using? Is the problem related to an Android or iOS App?

    We'll get our team to look into this.


    Thanks for the feedback.

  • Zoroaster Kagami

    i have tried iOS 12.1.2
    device : SE and iphone 7
    both, not working

  • Markus Helmers


    I also had problems to connect to my android phone.

    Just a restart of the phone solved the problem !



  • Serge Tremblay

    I have many andoid devices, the one I use the most is a LG V20. When the problem arise no device can see pokit including Windows PC, laptop and BLE scanner. So the problem do not came from the phone side. I have tighten the battery contact and it works a lot better now. Many days without any problem.

  • Ted Timmons

    Mine wasn't working, I rebooted and it works.


    Android 'P', Pixel 3.

  • Frédéric Wilmus

    Same here.
    The phone "sees" the Pokit by scanning arout it (and non, I'm pairing the Pokit this way, just looking at...).
    I rebooted the phone, I rebooted the Pokit, no improvement.

    It worked previously.

    I'm more and more disappointed after the "customs' incident" :-/


  • Frédéric Wilmus

    After reading the comments here, I tried something easy.
    In fact, I allowed the localisation permission to use the BLE, as requested, BUT, I didn't activate the localisation in the menu.
    I tried that ans.... Shazaaaaam, no more [sentence of the dead].

  • Pokit Support Team

    Hi All,

    We are trying to identify what the problem is with those who cannot even list their Pokits on the App. The best way to make sure that Pokit is working is to install a Bluetooth Scanner App. An example of this for iOS could be the BLU Tool App:

    Once you install it you can start scanning for devices and Pokit should show up on the list like shown on the image below.

    If the Scanner shows Pokit listed but you can't see it on the Pokit App, then the problem is related to the Bluetooth permissions.

    If you don't see Pokit on any of the apps, then it could be that Pokit is connected to a different device. Remove the battery and make to reset Pokit and the scan again.


    Hope this helps. 



  • Serge Tremblay

    The firmware update did fix this problem. Thank you very much I really like this product.


Please sign in to leave a comment.

Powered by Zendesk